XV100
MICRO PANEL
## Contents

1. **General**
   - Document Index ................................................................. 5
   - Device Variants ............................................................... 5

2. **Commissioning of the Device**
   - General Remarks to Wiring .............................................. 7
   - Starting the device ............................................................. 7
   - Switching off the device ................................................... 7
   - Ethernet ............................................................................. 8
     - Examining and Adjusting of the IP-Address of the Device ... 9
     - Wiring ........................................................................... 10
     - Test the Ethernet Connection .......................................... 10

3. **The first PLC Program**
   - PLC License Point on the Device ........................................ 11
   - Installation of the PLC Runtime System on the Device ....... 11
   - Programming the PLC–Programs with XSoft-CoDeSys-2 ...... 16
   - Installation of the PLC runtime starting out of XSoftCoDeSys-2 .. 18
   - Download of the program to the Device ......................... 19
   - Symbol-File Configuration ................................................ 21

4. **The first GALILEO Project**
   - Generate new Project ...................................................... 27
   - Select Device ................................................................. 28
   - Select PLC ....................................................................... 29
   - Generate Mask ............................................................... 30
   - Generate Variable Structure .......................................... 32
   - Generate Display Object ............................................... 35
   - Compile Project ............................................................. 36
   - Simulate Project on the PC ............................................. 37
   - Download Project to the Device ....................................... 38
     - Start FTP-Server on the Device ..................................... 38
     - Setup FTP Path in GALILEO .......................................... 39
     - Download of a Project ................................................. 41

5. **Operation from the Internal Flash or SD-Card**
   - Switch between Booting from the Internal Flash or SD-Card ... 43
   - Version Change of the Operating System .......................... 44

6. **File Update via SD-Card (Autolaunch)** ........................... 45
1 General

This documentation should facilitate the introduction to the handling of the XV100 touch panels from Eaton Automation. In order to ensure a fast commissioning of the device it is necessary to follow the explanations and references carefully.

The commissioning of the device, communication, PC program usage and project generation with GALILEO and XSoft-CoDeSys-2 will be described step by step.

For the description in this documentation the following versions of GALILEO and XSoft-CoDeSys-2 were used:
- GALILEO V7.2.2
- XSoft-CoDeSys V2.3.9 SP2

The illustrated pictures and described functions can differ if newer or different versions of the programs are used.

Furthermore for the print screens a 3.5" device (color) was used. For other device variants no changes in functionality apply.

1.1 Document Index

<table>
<thead>
<tr>
<th>Topic</th>
<th>Document</th>
<th>Doc. Number</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>MN04802006Z</td>
</tr>
<tr>
<td></td>
<td>It is also part of the GALILEO help</td>
<td></td>
</tr>
<tr>
<td>[3] Network</td>
<td>System Description Networks in Brief</td>
<td>MN05010009Z</td>
</tr>
</tbody>
</table>

(The index is not exclusive)

These helpful documents can be downloaded from our home page (www.eaton-automation.com), «DOWNLOADS» section.

1.2 Device Variants

The devices of the product class XV100 are available in different variants. Please find further information on our homepage www.eaton-automation.com or ask your local contact about possible device versions.
1 General
2 Commissioning of the Device

2.1 General Remarks to Wiring

- Cabling should be carried out with special care in order to ensure interference-free operation. The EMC values stated in the technical data can only be guaranteed if the connections and cables are prepared according to the specifications stated. The cabling must be laid separately from low-voltage cables or isolated with double or reinforced insulation.

  ➔ Further information, see Document [1] «Operating Instructions MICRO PANEL XV-1x2», Chapter «Installation».

2.2 Starting the device

Energize the device. ➔ The device will boot. If the device does not boot up and/or if an error message appears while starting (booting) the device, see Document [1] «Operating Instructions MICRO PANEL XV-1x2», Chapter «Troubleshooting».

  ➔ There is no runtime software for the visualization or optional PLC installed on the device. From the respective software package e.g. visualization (GALILEO) and optional PLC (XSoft-CoDeSys-2) you can install the runtimes on the device.

2.3 Switching off the device

De-energize the device.

  ➔ The lifespan of the backlight can be increased by reducing the brightness, see Document [2] «MN05010007Z System Description Windows CE».
2 Commissioning of the Device

2.4 Ethernet

The Ethernet interface of the device is used for engineering the visualization “GALILEO” as also programming the PLC with “XSoft-CoDeSys-2”. To commission the communication between the device and the PC follow the next described steps.

An IP-Address always consists out of a network and computer address. The network mask specifies which bits belong to the network and which do not.

Select for the device a free computer address from the local network. You can determine the network address of your PC under start → setting → network and telecommunications connections → properties → characteristics. Select out of the list Internet protocol (TCP/IP) and press the button “properties”.

Example:

<table>
<thead>
<tr>
<th>IP-Address PC:</th>
<th>192.168.0.71</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP-Address:</td>
<td>255.255.255.0</td>
</tr>
<tr>
<td>SubNetMask:</td>
<td></td>
</tr>
<tr>
<td>This means:</td>
<td>192.168.0</td>
</tr>
<tr>
<td>Computer-Address:</td>
<td>71</td>
</tr>
</tbody>
</table>

Select an IP-Adresse for the device:

| Network-Address:           | 192.168.0     |
| Computer-Address:          | 72 (Number between 1-254 and not any already used in the local network) |

→ IP-Address device:

| IP-Address:                 | 192.168.0.72 |
| SubNetMask:                 | 255.255.255.0|

The usage of the same address twice can cause critical network problems.
2.4.1 Examining and Adjusting of the IP-Address of the Device

Power up the device.

- If an information window appears after booting please close it.

After Windows CE has booted press the Start button and change to the menu Programs → Control Panel.

Double-click the icon “Network”.

Double-click the icon “ONBOARD1”.

2 Commissioning of the Device

A window ‘FEC Ethernet Driver’ will open. Select the desired IP address and subnet mask. Use the gateway only when needed then push OK.

The IP address and subnet mask must be consistent to the network configuration of the PC respectively the company network. In doubt ask your network administrator.

2.4.2 Wiring
Connect the device directly to the PC with an ethernet crossover cable. If you use an ethernet hub or switch use a 1-to-1 patch cable.

2.4.3 Test the Ethernet Connection
To test the connection open the “Dos-Shell” on your PC over Start ➔ Programs ➔ Accessories and ping the IP address of the device. (ping 192.168.0.72).

If the device does not answer then contact your network administrator.

➔ Further information, see Document [1] «Operating Instructions MICRO PANEL XV-1x2», Chapter «Installation».
➔ Further information, see Document [2] «MN05010007Z System Description Windows CE».
3 The first PLC Program

3.1 PLC License Point on the Device

The PLC runtime needs additional license points on the device. The XV100 devices of the classification type XV-1x2-...-PLC, XV-1x2-...-TVRC... and XV-1x2-...-TWRC... are delivered with 240 license points and are intended for operation as HMI devices and as control devices (HMI-PLC).

3.2 Installation of the PLC Runtime System on the Device

The XV100 devices do not contain the PLC runtime. The PLC runtime can be transferred to the device with the tool "TargetFirmwareWinCE". This tool can be started from the windows environment or from inside the XSoft-CoDeSys-2 development environment (see Chapter 3.4).

Requirement: The XSoft-CoDeSys-2 Software (CoDeSys) must be installed correctly on the PC. You can find the current XSoft-CoDeSys-2 software on our homepage (www.eaton-automation.com) under <DOWNLOADS → SOFTWARE → XSoft-CoDeSys-2>. For unrestricted operation of XSoft-CoDeSys-2 you need a license code. Please contact your sales vendor for this.

Perform the Installation from the Windows Surface:

Start the tool "TargetFirmwareWinCE_V2.4.8" on your PC through clicking:
Start → Programs → Eaton → CAA-Targets → XC-XV-Targets V2.3.9 SP2 → Firmware → XV-1xx
After starting the setup the follow the dialog until the following window appears.
Select the desired installation type and execute the next steps:

- **FTP Installation (suggested routine):**
  
  The installation of the PLC runtime is done over FTP.

  **Required steps:**
  
  - Ensure that the device is connected to your PC via ethernet.
  - Start the device.
  - Start the FTP-server on the device by clicking `Start → Programs → Communications → FTP Server`.
  - Continue the setup on the PC until the following dialog window appears.

  - Select „Boot behaviour“. Please note, that the operating system is not selected. For the installation of the operating system, see Chapter 5.2.
  - Click on the button “Next>”.

![FTP Installation Wizard](image-url)
- Select the destination: “Internal storage” if the PLC runtime and PLC project should be stored internally on the device. Select “Removable drive” if the PLC runtime and PLC project should be stored on the SD-card and should also be started from the SD-card (also see Chapter 5). Click the button „Next“.

- Enter the IP-address of the target device. Continue the setup procedure.
- After finishing the installation restart the device to start the PLC runtime.
Installation to a Removable drive (for operation from SD Card (see Chapter 5)):
The installation of the PLC runtime applies directly to the Removable drive (SD card) on the PC.

Required steps:
- Connect the Removable drive to your PC.
- Continue the setup routine on your PC until the following dialog appears.

- Select the Removable drive root in the directory through selecting the disk (disk character).
- Continue with the setup.

- Select „Boot behaviour“. Please note, that the operating system is not selected. For the installation of the operating system, see Chapter 5.2.
- Click on the button „Next“.
- After completing the installation, put the removable drive back in the device. (The device has to have power off).
3 The first PLC Program

- Restart the device to start the PLC-runtime.

**Installation to a local Directory:**

All files of the PLC runtime will be installed to a local directory on your PC.

Required steps:
- Fully complete setup.
- Copy the whole contents of the directory “\XV-1xx\” (you can find it in the newly created directory on your PC) manually on the device under ‘\InternalStorage\’ or on the SD-card depending on the boot operation type (see Chapter 5)
- Restart the device to start the PLC-runtime.

After successfully installation of the PLC runtime and reboot of the device, a status display for the PLC runtime will appear on the device (after clicking in the taskbar).

If a visualization is already installed on the device and if this visualization hides the status display, you can stop the visualization by pressing the CTRL button of the device.
3.3 Programming the PLC–Programs with XSoft-CoDeSys-2

**Requirement**: The XSoft-CoDeSys-2 software (CoDeSys) must be installed correctly on your PC and started. On the device the PLC runtime must be installed correctly.

Over menu File → New, you can start a new project.

Before you can start programming you have to select the device type in the Dialog window “Target Setting”.

Please select the target „XV-1xx-V2.3.9 SP2“.

In the dialog window that appears acknowledge with “OK”.

In the following dialog window you can now generate a programming unit. In the shown example the new POU “PLC_PRG” in the programming language “ST” is generated.
After that you can open the POU “PLC_PRG” in the register “POUs” and write a basic line of code:

\[ \text{hmiCounter}:=\text{hmiCounter}+1; \]

After entering “\text{hmiCounter}:=\text{hmiCounter}+1;” and pressing “Return” a dialog window for variable declaration appears. Select the variable type “INT” and press OK.

In the declaration field the variable „hmiCounter“ is displayed.

Select in the menu Project \( \rightarrow \) Rebuild All to compile the project. If the test program compiles error free then it is ready to be downloaded.
3.4 Installation of the PLC runtime starting out of XSoftCoDeSys-2

The XV100 devices do not contain the PLC runtime. The PLC runtime can be transferred to the device with the tool „TargetFirmwareWinCE“ This tool can be started from the windows environment or from inside the XSoft-CoDeSys-2 development environment (see Chapter 3.2).

Perform the Installation from the XSoft-CoDeSys-2 Development Environment:

Requirements: The target system in target system setting is correct.

1. Change to the register „Resources“ in the object organizer window of your XSoft-CoDeSys-2 project
2. Select „PLC Configuration“
3. Select the register „Other parameters“
4. Start the installation of the runtime system by pressing the start button
Select in the following dialog the desired version (min V2.4.8) of the runtime system.

After the start of the setup (by double-click) follow the installation instructions in the dialog. For further explanations, see Chapter 3.2.

3.5 Download of the program to the Device

Select in the menu Online → Communication Parameters and generate a new communication channel (New…).

Select „TCP/IP (Level 2 Route)“ from the possibilities and give the communication connection a name e.g. “MyPanel” and Acknowledge the dialog with OK.
Enter in the field “Address” the IP-address of your device (e.g. 192.168.0.72). To do this you have to double click on “localhost” and put in the IP-address and press the “return-key” to end the input. Acknowledge the dialog with OK.

Make sure that in the menu Online → Simulation Mode is deactivated (no checkmark should be set). Afterwards you can download the program on the device via Online → Login. You can start the program with Online → Run.

To have the PLC permanent on the device, you have to generate a boot project on the device. If this is not done then the program is lost when the power is turned off. To save a boot project on the device, make sure you are logged in (Online → Login) and then select Online → Create boot project.

Further topics to the PLC can be found in the helpful documentation to XSoft-CoDeSys-2.
3.6 Symbol-File Configuration

The communication between controller and a possible visualization is done over a symbolic address of the variables. To be able to do that a symbol configuration has to be generated. Furthermore the through this process generated symbol file can also be used as a variable import file for the visualization. Through the import of the symbol file in the visualization all generated variables name (symbols) in the PLC are known to the visualization and do not have to be entered again.

The symbol file is used as the basis of communication. The contents of the symbol file are configured in the PLC-development platform. When compiling the symbol file is then generated and when downloading the program to the PLC also the symbol file is downloaded.

Out of performance reasons it is suggested that only variables that are needed in the visualization should be exported to the symbol file. Thus the variable field should be structured. This can be applied as example by defining a global variable area where the variables are separated between variables for visualization and variables that are not used in the visualization.

Procedure:

In case you have not saved the PLC project yet, save the project via the menu File → Save as… on your PC.

Generation of a new variable list:

- Under the project tree click on the register “Resources”.
  - The resource-project tree will open.
- In the resource-project tree open the directory “Resource/Global Variables”.

![Image of PLC program management interface](image-url)
Click with the right mouse button the entry "Global Variables" and select "Add Object...".

In the dialog window that appears enter the desired name of the variable list and confirm with pressing OK.

Set up the symbol configuration for the symbol file:
- Ensure that the function “Simulation Mode” in the menu “Online” is not active (no checkmark is to be seen)
Click in the menu Project → Options... and select the category “Symbol configuration” and activate the point “Dump symbol entries”.

- With the function “Dump symbol entries” a symbol file will be generated every time the project is compiled.

Define from which objects the variables should be taken to export into the symbol file:

- Click on the button „Configure symbol file...“.
- In general all objects are selected. That is why you should deactivate for all objects the option „Export variables of object“.
- In the object tree open the subdirectory „Resources \ Global Variables“.
- Select the variable list that you would like to export.
- Activate the option „Export variables of object“ and confirm with OK.

Confirm the project options with OK.

Allocate the needed variables for the visualization to the global variables specified for visualization:
- In the POU-project tree double click on the programming unit in which are the variables that you would like to allocate to the variable list.

Put the cursor in the variable that you would like to allocate.
3 The first PLC Program

- Click in the menu Edit ➔ Auto Declare...
  - The window “Declare Variable” will open.
- Select the class, Class", "VAR_GLOBAL".

- Select under “Symbol list” the variables list you would like to allocate to.

- Confirm the adjustments with OK.

Compile and download the PLC project to the device:
- Click in the menu Project ➔ Rebuild all to compile the project.
- Click in the menu Online ➔ Login to log into the device.
- Click in the menu Online ➔ Run to start the PLC project on the device.
- Click in the menu Online ➔ Create boot project to save the project on the device.
- Click in the menu Online ➔ Logout to log off of the device.

The performance of visualization (Refresh cycle) can be increased by grouping the individual SPS variables in data structures “Struct” or data fields “array”. The data structures and data fields are transferred in a communication package between the XSoft-CoDeSys-2 runtime system and GALILEO runtime system, individual variables are sent in individual packages behind each other.

Further topics to PLC you may find in the helpful XSoft-CoDeSys-2 documentation.
3 The first PLC Program
4 The first GALILEO Project

It consists of a simple application which should show the projecting of the connection of the HMI to the PLC of the touch panel XV100.

Requirements: The GALILEO visualization software must be installed correctly. You can find the current GALILEO software on our homepage (www.eaton-automation.com) under <DOWNLOADS → SOFTWARE → GALILEO>. The XV100 devices are supported from GALILEO version V7.0.3 onward. For unrestricted operation of GALILEO you need a license code. Please contact your sales vendor for this.

4.1 Generate new Project

Start the GALILEO software. The first step is to generate a new HMI project.

Menu Project → New.

In the now appearing window “New Project” you should first create a new project directory.

Example: MyFirst

This is used to generate a hierarchical overview when have more than one project.

Hereupon the folder must be opened. Following this you should enter in the input field the desired file name.

Example: MyFirst
4.2 Select Device

The window “Panel Selection” is opened automatically when a new project is generated. It can also be opened via the menu Config → Panel Type and at a later time edited.

Click “Panel Selection” and select the device type:

Confirm the adjustments with OK.

For the selection field “Format” the option Landscape is chosen whereby the device will be used in horizontal operation.
4.3 Select PLC

The window “Select PLC” will also be opened automatically when a new project is generated. It can be opened over the menu Config → Select Communication and edited later.

Depending on the device type CAN, MPI or RS232 different communication types are available. Select under “Add” the communication to the PLC.

The following example uses the integrated PLC as controller type. Also more than one controller can be selected. So that one PLC can be connected over MPI (Onboard) and another one to the internal PLC over CoDeSys MXpro. To keep in mind is the different types of addressing the variables.

With OK the new project is configured.
4.4 Generate Mask

The first step is to generate an empty mask (picture). Register card Masks, Masks (standard) → select right mouse button „New“:

Give the name e.g.: „Startmask“. The mask can be given specific properties like screen saver, colour, type, etc. These can be configured under the sub menu “Mask Settings”.

Following this you can insert objects into the mask using the Objects Toolbar. Please use the help-menu to inform yourself about the single objects and their capability.
GALILEO help system with detailed examples and instructions to every object.

As an example you can find under: <Content / Demos / Fast Start> an animated guideline for your first GALILEO project.
4.5 Generate Variable Structure

In our small example we are displaying a numeral value of the PLC. For this we must first generate the used variables. This is accomplished over the register card Tags.

If the integrated PLC is used and the symbol file of the PLC was compiled right the variables names can be imported.

Change to the register card „Tags“; move the mouse cursor to any variable type e.g. “bit” and press the right mouse button. A dialog will open where you have to select “Import”.

Select the symbol file of the PLC program as the Import file. You can find the symbol file in the same directory where the PLC program is saved on the PC. Confirm the dialog with pressing the “Start” button. Also see Chapter 3.6.

Through the import of the PLC variable „hmiCounter“ from Type WORD the variable is inserted into the tag list. The green marking of the variable shows that a addressing to the PLC has already occurred.
To use variables from another controller type or to use variables without using the import function you have to use the following procedure:

E.g. a byte variable:

Position the mouse cursor on the variable type “byte” and press the right mouse button and select “New Tag”. Then enter the variable name. Thus the variable is generated but marked blue. The colour blue means that the variable has no address and thus has no possible communication to as PLC. This is how you generate a local visualization variable. With a double click on the variable a Tag Settings window to the variable will open.

In the Tag Settings dialog under the register card “Address” you can click on the Address “…” button and enter the address of the PLC. This address depends on the type of PLC selected. If you are communicating to the internal PLC you must also enter the name of the symbol file. (This only applies to global PLC variables.)
When communicating to another controller the address has to be entered specific to the protocol. In the dialog “Setting address” you can see and select the possible nomenclature needed. According to the desired nomenclature the following input fields for addressing the variables are possible.

The displayed example shows the address of a variable for a S7 controller over MPI. The nomenclature of a variable is selected out of the data block of the controller. The address is herewith select as DB12 byte 144.

After following the address the variable in the variables list is marked green (=addressed).
4.6 Generate Display Object

Insert an object of the type “Value Entry / Display” in the start mask:

To do this you have to click in the object list on ![object list](image), and then draw via mouse and pressed mouse button the object in the desired size and position on the Startmask.

Through a double click on the new generated object field the property window appears. Select from the Tag list the desired variable and confirm the dialog with OK.
Value Entry / Display object with linked variable. (-88888)

We have finished our small project and now want to go to the next step of the project; compiling and downloading to the device.

### 4.7 Compile Project

Via the menu Build ➔ Compile or over the button the project will be compiled. The compiling procedure is protocolled in a display window. Eventual errors will be displayed red. Through scrolling the detailed error message can then be read.
4.8 Simulate Project on the PC

Via menu Build → Start Project Inspector or over the button you can start the simulation of the project on your PC.

PC Simulation of the project (Project Inspector)
4.9 **Download Project to the Device**

Now the generated project should be downloaded to and started on the device.

4.9.1 **Start FTP-Server on the Device**

To get a connection between the PC and the device you must start the FTP server on the device.

Select on the device: **Start → Programs → Communication → FTP Server**

The FTP server is now started and ready.

👉 The FTP server can also be started automatically when the device is booted. To change the Window CE start up behavior please look in the GALILEO help “Micro Panels with Windows CE Topics”.

👉 Further information, see Document [2] «MN05010007Z System Description Windows CE».

👉 Further information, see Document [3] «MN05010009Z System Description Networks in Brief ».
4 The first GALILEO Project

4.9.2 Setup FTP Path in GALILEO

To be able to download the project to the device the parameters for the project transfer to the device must be generated. Change to the download dialog via the menu Build → Download (local, FTP) or over the button

In the window “Download” click on the button “FTP path”. The window “FTP Connections” will appear.

Click on “New Connection”. The window “Properties : FTP-Connection” will appear.

Enter a title, the IP-address of the device and the path for the download to the device. With a click on “Browse” you should already find the path of the \InternalStorage of the device. But for this an active connection and the IP-address of the device must exist. Alternatively you can switch to the directory \StorageCard (SD card) (see Chapter 5)
Click on “OK” to save the new parameters.

The connection with its title should now be selectable. Click on the desired connection and confirm with “Close”.

The selected FTP path can now be seen in the field “Local/FTP path”.

Click on “Close” to confirm the changes.
4.9.3 Download of a Project

After the visualization project has been generated and compiled and the target settings have been completed you can now start the project download to the device. For this select the menu Build → Download (local, FTP) or press the button.

The Download dialog appears.

Start the project download over the button "Download". During the project transfer you can see the progress. Eventual you will be asked if you want to also download updates of the operating system or visualization runtime (GRS) over dialogs.

If the project transfer is completed the following dialog will be displayed. Select now “Start GRS” (GRS = GALILEO Runtime System) to start the visualization project on the device.
While the GRS starts status information will be displayed. Following that your designed mask will be displayed.

Display of the start mask from the project MyFirst. When the PLC program is started on the device the value must be constantly changing.

If there is no connection to the PLC then a cyclic error message will be displayed with the information which variables are without communication.
5 Operation from the Internal Flash or SD-Card

XV100 devices which are equipped with an optional SD-card can optionally operate from internal flash as also from SD-card.

Operation from the SD-card:
- The OS that is stored on the SD-card is loaded
- The runtime for HMI and PLC are started from the SD-card
- The HMI and PLC project is stored on the SD-card

5.1 Switch between Booting from the Internal Flash or SD-Card

Turn on the power of the device. If an info-window appears after booting, close it.

As soon as Windows CE has booted press the Start button and change to the menu Programs → Control Panel.
Double-click the icon „BootDevice“.

You can select from the following settings:

**Boot from: InternalStorage**

Herewith the device boots from the device internal stored OS.

⇒ Further information, see Document [2] «MN05010007Z System Description Windows CE», Chapter «Startup behavior».

**Boot from: StorageCard**

Herewith the device boots from the SD-card stored OS.

⇒ Further information, see Document [2] «MN05010007Z System Description Windows CE», Chapter «Startup behavior».

### 5.2 Version Change of the Operating System

The operating system of the XV100 is stored on the internal flash memory in delivery condition. The usage of newer function can require a version change of the operating system. In general this is done through the programming software GALILEO or XSoft-CoDeSys-2. GALILEO (from version V7.2.0 onward) checks while downloading a project the operating system version and offers over a dialog a download of a different version of operating system.

Older version of the software such as (Version of GALILEO previous to V7.2.0 or MXpro versions) must not be used for an operating-system download. Exceptions are XV102 3.5” devices.

⇒ For a manual change of the operating system, see Document [2] «MN05010007Z System Description Windows CE», Chapter «Startup behavior».
File Update via SD-Card (Autolaunch)

XV100 devices (OS Version V2.24.0 and upwards) can run an update automatically via an SD card. The SD card must be configured to this end.

In the case of an update-from-file the following functions can be fulfilled:

- Update of the Windows CE OS Version
- Installation or update of the GALILEO and XSoft-CoDeSys-2 runtime software.
- Project installation or update of visualization and SPS projects.
- Installation and update of any files

The device recognizes the insertion of an SD card and executes the configuration actions. In order to configure the update, the file AutoLaunch.inf is used. This file also enables configuration of whether the actions should be executed on insertion of the SD card or only on starting the device. For file-update or copying of the files a separate .BAT file is started. In this .BAT file the command-line instructions for the desired actions can be defined.

Further information, see Document [2] «MN05010007Z System Description Windows CE»:
- Chapter «AutoLaunch»
- Chapter «Extended Copy (ExtCopy)»

We wish you lots of success and fun with your XV100.